AWS have resolved the incident on their end, and Atlassian reported that they are not seeing problems in their systems anymore.
Posted Oct 21, 2025 - 08:56 UTC
Update
Our cloud provider AWS is continuing to recover from the outage earlier today, but we are still experiencing degraded performance because of this. Atlassian are also affected because of this outage. No ETA has been provided yet by the cloud provider and we continue to monitor the situation.
Posted Oct 20, 2025 - 20:01 UTC
Monitoring
AWS appears to have fixed the issue, and our services have recovered. We are monitoring the situation closely.
Posted Oct 20, 2025 - 09:40 UTC
Identified
We have investigated and we are continuing to experience widespread issues due to an ongoing AWS incident with the US-EAST-1 Region ( https://health.aws.amazon.com/health/status ) . We will continue to provide update as the situation evolves.
Posted Oct 20, 2025 - 09:13 UTC
Investigating
We're experiencing widespread issues due to an ongoing provider outage
Posted Oct 20, 2025 - 08:44 UTC
This incident affected: Timesheets, Planner, Cost Tracker, JIRA, Tempo for Slack, and Tempo for Jira Cloud Help Center.